«

»

dec 12

Függvények egymásba ágyazása a függvény szerkesztőben

Ebben a bejegyzésben azt szeretném megmutatni, hogyan tudtok nagyon egyszerűen egymásba ágyazott függvényeket készíteni a függvény szerkesztő segítségével.

Formula_editor1

A gyakorlatban egymásba ágyazott függvények gyakran a HA (IF) függvény esetében fordulnak elő, például amikor szöveget akarunk hozzárendelni érték tartományokhoz:

Ha A1 >= 10, akkor “magas”
Ha A1 >=5, akkor “közepes”,
egyébként “alacsony”.

Egymásba ágyazott függvénnyel így írható fel:

=HA(A1>=10;”magas”;HA(A1>=5;”közepes”;”alacsony”))

=IF(A1>=10,”magas”,IF(A1>=5,”közepes”,”alacsony”))

Ezt a függvényt nagyon egyszerűen összerakhatod a függvény szerkesztővel. Kattints az ikonra, válaszd ki a HA függvényt és kezdd el kitölteni a paramétereket. A Hamis (False) ágra kell beágyaznod a második HA függvényt – s most jön a trükk! A beágyazáshoz kattints a név mezőben megjelenő HA függvényre:

Formula_editor2-1

Újra megnyílik a függvény szerkesztő ablak, amiben már a beágyazott függvényt paraméterezheted.

 

Ha másik függvényt szeretnél beágyazni, akkor a név mező legördülő nyilacskájára kattintva választhatsz a legutóbb használt, vagy az összes függvény közül:

Formula_editor3

Találtam erről a trükkről egy kis angol nyelvű youtube videót is, amiben szépen el van magyarázva a beágyazott HA függvény, bár sajnos az a fontos elem, hogy más függvényt is beágyazhatsz, hiányzik belőle.

Remélem, hasznosnak találjátok ezt az apró kis trükköt!

 


Kérdezz tőlünk Excel segítő csoportunkban vagy kövesd az Adatkertészetet a Facebookon!


Vélemény, hozzászólás?

Az email címet nem tesszük közzé. A kötelező mezőket * karakterrel jelöljük.

Az alábbi HTML kódok használhatóak: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

css.php